const regex = new RegExp('((?P<fulldate>(?P<date>(\\d{4}-\\d{2}-\\d{2}))T(?P<time>(\\d{2}:\\d{2}:\\d{2}(?:\\.\\d+)?)))(?P<tz>(Z|[\\+-]\\d{2}:\\d{2})?))', 'gm')
const str = `CAST(N'2016-01-19T15:21:32.59+02:00'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}