package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?P<fulldate>(?P<date>(\d{4}-\d{2}-\d{2}))T(?P<time>(\d{2}:\d{2}:\d{2}(?:\.\d+)?)))(?P<tz>(Z|[\+-]\d{2}:\d{2})?))`)
var str = `CAST(N'2016-01-19T15:21:32.59+02:00'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}