#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/www\.bugaboo\.com\/(es|de|gb|nl|us)-.{2}\/(strollers|carritos|kinderwagen|pushchairs).*\.html"
Local $sString = "https://www.bugaboo.com/es-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html" & @CRLF & _
"https://www.bugaboo.com/es-es/carritos/bugaboo-fox-2/carrito-bugaboo-fox-2-con-silla-y-capazo-PM001601.html" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/de-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html" & @CRLF & _
"https://www.bugaboo.com/de-de/kinderwagen/bugaboo-fox-2/bugaboo-fox-2-kinderwagen-mit-sitz-und-liegewanne-PM001601.html" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/gb-en/pushchairs/bugaboo-fox-2/bugaboo-fox-2-seat-and-carrycot-pushchair-PM001601.html" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/nl-nl/kinderwagens/bugaboo-fox-2/bugaboo-fox-2-kinderwagen-met-stoel-en-wieg-PM001601.html" & @CRLF & _
"https://www.bugaboo.com/nl-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/us-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001602.html" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/de-de/kinderwagen/bugaboo-cameleon-3-plus/bugaboo-cameleon-3-plus-kinderwagen-mit-sitz-und-liegewanne-PM00018.html " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/fi-en/strollers/bugaboo-cameleon-3-plus/bugaboo-cameleon-3-plus-seat-and-bassinet-stroller-PM00018.html" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")