import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/www\\.bugaboo\\.com\\/(es|de|gb|nl|us)-.{2}\\/(strollers|carritos|kinderwagen|pushchairs).*\\.html";
final String string = "https://www.bugaboo.com/es-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html\n"
+ "https://www.bugaboo.com/es-es/carritos/bugaboo-fox-2/carrito-bugaboo-fox-2-con-silla-y-capazo-PM001601.html\n\n\n\n"
+ "https://www.bugaboo.com/de-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html\n"
+ "https://www.bugaboo.com/de-de/kinderwagen/bugaboo-fox-2/bugaboo-fox-2-kinderwagen-mit-sitz-und-liegewanne-PM001601.html\n\n\n\n\n\n"
+ "https://www.bugaboo.com/gb-en/pushchairs/bugaboo-fox-2/bugaboo-fox-2-seat-and-carrycot-pushchair-PM001601.html\n\n"
+ "https://www.bugaboo.com/nl-nl/kinderwagens/bugaboo-fox-2/bugaboo-fox-2-kinderwagen-met-stoel-en-wieg-PM001601.html\n"
+ "https://www.bugaboo.com/nl-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html\n\n\n"
+ "https://www.bugaboo.com/us-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001602.html\n\n"
+ "https://www.bugaboo.com/de-de/kinderwagen/bugaboo-cameleon-3-plus/bugaboo-cameleon-3-plus-kinderwagen-mit-sitz-und-liegewanne-PM00018.html \n\n\n"
+ "https://www.bugaboo.com/fi-en/strollers/bugaboo-cameleon-3-plus/bugaboo-cameleon-3-plus-seat-and-bassinet-stroller-PM00018.html\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}