use strict;
my $str = 'https://www.bugaboo.com/es-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/es-es/carritos/bugaboo-fox-2/carrito-bugaboo-fox-2-con-silla-y-capazo-PM001601.html
https://www.bugaboo.com/de-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/de-de/kinderwagen/bugaboo-fox-2/bugaboo-fox-2-kinderwagen-mit-sitz-und-liegewanne-PM001601.html
https://www.bugaboo.com/gb-en/pushchairs/bugaboo-fox-2/bugaboo-fox-2-seat-and-carrycot-pushchair-PM001601.html
https://www.bugaboo.com/nl-nl/kinderwagens/bugaboo-fox-2/bugaboo-fox-2-kinderwagen-met-stoel-en-wieg-PM001601.html
https://www.bugaboo.com/nl-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/us-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001602.html
https://www.bugaboo.com/de-de/kinderwagen/bugaboo-cameleon-3-plus/bugaboo-cameleon-3-plus-kinderwagen-mit-sitz-und-liegewanne-PM00018.html
https://www.bugaboo.com/fi-en/strollers/bugaboo-cameleon-3-plus/bugaboo-cameleon-3-plus-seat-and-bassinet-stroller-PM00018.html
';
my $regex = qr/https:\/\/www\.bugaboo\.com\/(es|de|gb|nl|us)-.{2}\/(strollers|carritos|kinderwagen|pushchairs).*\.html/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}