const regex = /https:\/\/www\.bugaboo\.com\/(es|de|gb|nl|us)-.{2}\/(strollers|carritos|kinderwagen|pushchairs).*\.html/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/www\\.bugaboo\\.com\\\/(es|de|gb|nl|us)-.{2}\\\/(strollers|carritos|kinderwagen|pushchairs).*\\.html', 'gm')
const str = `https://www.bugaboo.com/es-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/es-es/carritos/bugaboo-fox-2/carrito-bugaboo-fox-2-con-silla-y-capazo-PM001601.html
https://www.bugaboo.com/de-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/de-de/kinderwagen/bugaboo-fox-2/bugaboo-fox-2-kinderwagen-mit-sitz-und-liegewanne-PM001601.html
https://www.bugaboo.com/gb-en/pushchairs/bugaboo-fox-2/bugaboo-fox-2-seat-and-carrycot-pushchair-PM001601.html
https://www.bugaboo.com/nl-nl/kinderwagens/bugaboo-fox-2/bugaboo-fox-2-kinderwagen-met-stoel-en-wieg-PM001601.html
https://www.bugaboo.com/nl-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/us-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001602.html
https://www.bugaboo.com/de-de/kinderwagen/bugaboo-cameleon-3-plus/bugaboo-cameleon-3-plus-kinderwagen-mit-sitz-und-liegewanne-PM00018.html
https://www.bugaboo.com/fi-en/strollers/bugaboo-cameleon-3-plus/bugaboo-cameleon-3-plus-seat-and-bassinet-stroller-PM00018.html
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}