import Foundation
let pattern = #"https:\/\/www\.bugaboo\.com\/(es|de|gb|nl|us)-.{2}\/(strollers|carritos|kinderwagen|pushchairs).*\.html"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.bugaboo.com/es-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/es-es/carritos/bugaboo-fox-2/carrito-bugaboo-fox-2-con-silla-y-capazo-PM001601.html
https://www.bugaboo.com/de-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/de-de/kinderwagen/bugaboo-fox-2/bugaboo-fox-2-kinderwagen-mit-sitz-und-liegewanne-PM001601.html
https://www.bugaboo.com/gb-en/pushchairs/bugaboo-fox-2/bugaboo-fox-2-seat-and-carrycot-pushchair-PM001601.html
https://www.bugaboo.com/nl-nl/kinderwagens/bugaboo-fox-2/bugaboo-fox-2-kinderwagen-met-stoel-en-wieg-PM001601.html
https://www.bugaboo.com/nl-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001601.html
https://www.bugaboo.com/us-en/strollers/bugaboo-fox-2/bugaboo-fox-2-seat-and-bassinet-stroller-PM001602.html
https://www.bugaboo.com/de-de/kinderwagen/bugaboo-cameleon-3-plus/bugaboo-cameleon-3-plus-kinderwagen-mit-sitz-und-liegewanne-PM00018.html
https://www.bugaboo.com/fi-en/strollers/bugaboo-cameleon-3-plus/bugaboo-cameleon-3-plus-seat-and-bassinet-stroller-PM00018.html
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)