#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<major>\d+)[.](?<minor>\d+)[.](?<patch>\d+)([-](?<prerelease>[a-zA-Z0-9]*[^+]))?\b([+](?<buildCounter>\d+))?"
Local $sString = "0.12.3" & @CRLF & _
"0.12.3-alpha0001+12" & @CRLF & _
"0.12.3-SNAPSHOT+12" & @CRLF & _
"0.12.3-RC1+1" & @CRLF & _
"0.12.3-beta1+1333" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")