const regex = /(?<major>\d+)[.](?<minor>\d+)[.](?<patch>\d+)([-](?<prerelease>[a-zA-Z0-9]*[^+]))?\b([+](?<buildCounter>\d+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<major>\\d+)[.](?<minor>\\d+)[.](?<patch>\\d+)([-](?<prerelease>[a-zA-Z0-9]*[^+]))?\\b([+](?<buildCounter>\\d+))?', 'gm')
const str = `0.12.3
0.12.3-alpha0001+12
0.12.3-SNAPSHOT+12
0.12.3-RC1+1
0.12.3-beta1+1333
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}