import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<major>\\d+)[.](?<minor>\\d+)[.](?<patch>\\d+)([-](?<prerelease>[a-zA-Z0-9]*[^+]))?\\b([+](?<buildCounter>\\d+))?";
final String string = "0.12.3\n"
+ "0.12.3-alpha0001+12\n"
+ "0.12.3-SNAPSHOT+12\n"
+ "0.12.3-RC1+1\n"
+ "0.12.3-beta1+1333\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}