use strict;
my $str = '0.12.3
0.12.3-alpha0001+12
0.12.3-SNAPSHOT+12
0.12.3-RC1+1
0.12.3-beta1+1333
';
my $regex = qr/(?<major>\d+)[.](?<minor>\d+)[.](?<patch>\d+)([-](?<prerelease>[a-zA-Z0-9]*[^+]))?\b([+](?<buildCounter>\d+))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}