import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<[^>]*class=(\"|'))(\\b(foo)(\\w|\\-)*)*";
final String string = "<body>\n"
+ " <div style=\"margin-left:6px;\" class=\"foo-pink blfoo-pin-foo-kue red yellow bar-green -moz-FF foo-pink moz-FF foo-pink\" >\n"
+ " <fieldset class=\"foo customClass foo clFieldsBar bar-try\" id=\"idField foo- bar-dfgdgdfg\"> \n"
+ " <legend><span>Qu'en pensez-vous ?</span></legend>\n"
+ " < id=\"idText\" class='foo- Comment_text fdgdgdfg -foo-ddede mso-whitespace' name=\"nameText barName\"></textarea> bar-deded foo-green\n"
+ " </fieldset>\n"
+ " class=\"blue dffsf sdf mso-green foo\"\n"
+ " </div> \n"
+ "</body>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}