$re = '/(<[^>]*class=("|\'))(\b(foo)(\w|\-)*)*/mi';
$str = '<body>
<div style="margin-left:6px;" class="foo-pink blfoo-pin-foo-kue red yellow bar-green -moz-FF foo-pink moz-FF foo-pink" >
<fieldset class="foo customClass foo clFieldsBar bar-try" id="idField foo- bar-dfgdgdfg">
<legend><span>Qu\'en pensez-vous ?</span></legend>
< id="idText" class=\'foo- Comment_text fdgdgdfg -foo-ddede mso-whitespace\' name="nameText barName"></textarea> bar-deded foo-green
</fieldset>
class="blue dffsf sdf mso-green foo"
</div>
</body>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);