const regex = /(<[^>]*class=("|'))(\b(foo)(\w|\-)*)*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<[^>]*class=("|\'))(\\b(foo)(\\w|\\-)*)*', 'gmi')
const str = `<body>
<div style="margin-left:6px;" class="foo-pink blfoo-pin-foo-kue red yellow bar-green -moz-FF foo-pink moz-FF foo-pink" >
<fieldset class="foo customClass foo clFieldsBar bar-try" id="idField foo- bar-dfgdgdfg">
<legend><span>Qu'en pensez-vous ?</span></legend>
< id="idText" class='foo- Comment_text fdgdgdfg -foo-ddede mso-whitespace' name="nameText barName"></textarea> bar-deded foo-green
</fieldset>
class="blue dffsf sdf mso-green foo"
</div>
</body>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}