// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)(<[^>]*class=("|'))(\b(foo)(\w|\-)*)*"#).unwrap();
let string = "<body>
<div style=\"margin-left:6px;\" class=\"foo-pink blfoo-pin-foo-kue red yellow bar-green -moz-FF foo-pink moz-FF foo-pink\" >
<fieldset class=\"foo customClass foo clFieldsBar bar-try\" id=\"idField foo- bar-dfgdgdfg\">
<legend><span>Qu'en pensez-vous ?</span></legend>
< id=\"idText\" class='foo- Comment_text fdgdgdfg -foo-ddede mso-whitespace' name=\"nameText barName\"></textarea> bar-deded foo-green
</fieldset>
class=\"blue dffsf sdf mso-green foo\"
</div>
</body>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}