# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"function (.*).*\((.*)\)"
test_str = ("PLAYER_BUFF_MINUTES = 10\n"
"FORCE_BUFF_MINUTES = 30\n\n"
"-- ------------------------------------------------------------------------------------\n\n"
"CHARGE_ENERGY = 100000\n\n"
"local charging_station_multiplier = 1\n\n"
"function ResetPlayer(playername)\n"
" if (game.players[playername] ~= nil) then\n"
" RemoveOrResetPlayer(game.players[playername], false, true, true, true)\n"
" SeparateSpawnsPlayerCreated(game.players[playername].index, true)\n"
" end\n"
"end")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.