re = /function (.*).*\((.*)\)/
str = 'PLAYER_BUFF_MINUTES = 10
FORCE_BUFF_MINUTES = 30
-- ------------------------------------------------------------------------------------
CHARGE_ENERGY = 100000
local charging_station_multiplier = 1
function ResetPlayer(playername)
if (game.players[playername] ~= nil) then
RemoveOrResetPlayer(game.players[playername], false, true, true, true)
SeparateSpawnsPlayerCreated(game.players[playername].index, true)
end
end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end