#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)InsertCodeInfo\((\w+),\s*\"([^\"]*)"
Local $sString = " InsertCodeInfo(pjlWarnCommunications, " & @CRLF & _
" "communications error");" & @CRLF & _
" InsertCodeInfo(pjlNormalOnline, " & @CRLF & _
" "Online");" & @CRLF & _
" InsertCodeInfo(pjlWarnOffline, " & @CRLF & _
" "offline");" & @CRLF & _
" InsertCodeInfo(pjlNormalAccessing, "Accessing"); #this is first match :(" & @CRLF & _
" InsertCodeInfo(pjlNormalArrive, "Normal arrive");" & @CRLF & _
" InsertCodeInfo(pljNormalProcessing, "Processing");" & @CRLF & _
" InsertCodeInfo(pjlNormalDataInBuffer, "Data in buffer");"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")