package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)InsertCodeInfo\((\w+),\s*\"([^\"]*)`)
var str = ` InsertCodeInfo(pjlWarnCommunications,
"communications error");
InsertCodeInfo(pjlNormalOnline,
"Online");
InsertCodeInfo(pjlWarnOffline,
"offline");
InsertCodeInfo(pjlNormalAccessing, "Accessing"); #this is first match :(
InsertCodeInfo(pjlNormalArrive, "Normal arrive");
InsertCodeInfo(pljNormalProcessing, "Processing");
InsertCodeInfo(pjlNormalDataInBuffer, "Data in buffer");`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}