import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "InsertCodeInfo\\((\\w+),\\s*\\\"([^\\\"]*)";
final String string = " InsertCodeInfo(pjlWarnCommunications, \n"
+ " \"communications error\");\n"
+ " InsertCodeInfo(pjlNormalOnline, \n"
+ " \"Online\");\n"
+ " InsertCodeInfo(pjlWarnOffline, \n"
+ " \"offline\");\n"
+ " InsertCodeInfo(pjlNormalAccessing, \"Accessing\"); #this is first match :(\n"
+ " InsertCodeInfo(pjlNormalArrive, \"Normal arrive\");\n"
+ " InsertCodeInfo(pljNormalProcessing, \"Processing\");\n"
+ " InsertCodeInfo(pjlNormalDataInBuffer, \"Data in buffer\");";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}