using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"InsertCodeInfo\((\w+),\s*\""([^\""]*)";
string input = @" InsertCodeInfo(pjlWarnCommunications,
""communications error"");
InsertCodeInfo(pjlNormalOnline,
""Online"");
InsertCodeInfo(pjlWarnOffline,
""offline"");
InsertCodeInfo(pjlNormalAccessing, ""Accessing""); #this is first match :(
InsertCodeInfo(pjlNormalArrive, ""Normal arrive"");
InsertCodeInfo(pljNormalProcessing, ""Processing"");
InsertCodeInfo(pjlNormalDataInBuffer, ""Data in buffer"");";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}