// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)InsertCodeInfo\((\w+),\s*\"([^\"]*)"#).unwrap();
let string = " InsertCodeInfo(pjlWarnCommunications,
\"communications error\");
InsertCodeInfo(pjlNormalOnline,
\"Online\");
InsertCodeInfo(pjlWarnOffline,
\"offline\");
InsertCodeInfo(pjlNormalAccessing, \"Accessing\"); #this is first match :(
InsertCodeInfo(pjlNormalArrive, \"Normal arrive\");
InsertCodeInfo(pljNormalProcessing, \"Processing\");
InsertCodeInfo(pjlNormalDataInBuffer, \"Data in buffer\");";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}