# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|\()[^)(]*+\K(\(((?>[^)(]+|(?1))*)\))/$2/gm;t' <<< "Record ID
What is the best food? (choice=Nachos)
What is the best food? (choice=Tacos (big bent nachos))
What is the best food? (choice=Chips with stuff)
Complete?
So ((this) one (has) (many) (inside)) (none here) (but (here) and (here))
Deeper nesting: (l0 (l1 (l2) l1 (l2) l1)) out (a (b) (b) a ((c) b)) out (no)"