using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\Q/path/to/dir/\E\K.+";
string input = @"/path/to/dir/file1
/path/to/dir/file2
/path/to/dir/
/path/to/dirt
/wrong/path/to/dir/file1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}