const regex = new RegExp('^\\Q/path/to/dir/\\E\\K.+', 'gm')
const str = `/path/to/dir/file1
/path/to/dir/file2
/path/to/dir/
/path/to/dirt
/wrong/path/to/dir/file1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}