using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^
(?:
(?!
.*?
( [0-9] ) # (1)
\1{3}
)
\S+
|
[a-z]{0,2}
[0-9]+
)
$";
string input = @"4444
11222
77722
sj76755
k4545
6j53
653aa
ss653aa";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}