$re = '/^
(?:
(?!
.*?
( [0-9] ) # (1)
\1{3}
)
\S+
|
[a-z]{0,2}
[0-9]+
)
$/mx';
$str = '4444
11222
77722
sj76755
k4545
6j53
653aa
ss653aa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);