// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^
(?:
(?!
.*?
( [0-9] ) # (1)
\1{3}
)
\S+
|
[a-z]{0,2}
[0-9]+
)
$").unwrap();
let string = "4444
11222
77722
sj76755
k4545
6j53
653aa
ss653aa";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}