package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^
(?:
(?!
.*?
( [0-9] ) # (1)
\1{3}
)
\S+
|
[a-z]{0,2}
[0-9]+
)
$`)
var str = `4444
11222
77722
sj76755
k4545
6j53
653aa
ss653aa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}