import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ \n"
+ "(?:\n"
+ " (?!\n"
+ " .*? \n"
+ " ( [0-9] ) # (1)\n"
+ " \\1{3} \n"
+ " )\n"
+ " \\S+ \n"
+ " | \n"
+ " [a-z]{0,2}\n"
+ " [0-9]+ \n"
+ ")\n"
+ "$";
final String string = "4444\n"
+ "11222\n"
+ "77722\n\n\n"
+ "sj76755\n"
+ "k4545\n"
+ "6j53\n"
+ "653aa\n"
+ "ss653aa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}