using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+(?:\.\d+)?[ '])?(\d+(?:(?:\.\d+|\d+\/\d+))?(?: \d+\/\d+)?)";
string input = @"5 6 (feet and inches separated by spaces)
5'6"" (feet and inches in the correct format)
5.2 6 (decimal feet separated by spaces)
5.2'6"" (decimal feet in the correct format)
5 6.1 (decimal inches separated by spaces)
5'6.1"" (decimal inches in the correct format)
5.2 6.1 (decimal feet and inches separated by spaces)
5.2'6.1"" (decimal feet and inches in the correct format)
5 6 1/2 (any combination above followed by a space and fraction)
5.2'6.1 1/2"" (again with decimals)
78"" (only inches)
78.4"" (only inches with a decimal)
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}