const regex = /(\d+(?:\.\d+)?[ '])?(\d+(?:(?:\.\d+|\d+\/\d+))?(?: \d+\/\d+)?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+(?:\\.\\d+)?[ \'])?(\\d+(?:(?:\\.\\d+|\\d+\\\/\\d+))?(?: \\d+\\\/\\d+)?)', 'g')
const str = `5 6 (feet and inches separated by spaces)
5'6" (feet and inches in the correct format)
5.2 6 (decimal feet separated by spaces)
5.2'6" (decimal feet in the correct format)
5 6.1 (decimal inches separated by spaces)
5'6.1" (decimal inches in the correct format)
5.2 6.1 (decimal feet and inches separated by spaces)
5.2'6.1" (decimal feet and inches in the correct format)
5 6 1/2 (any combination above followed by a space and fraction)
5.2'6.1 1/2" (again with decimals)
78" (only inches)
78.4" (only inches with a decimal)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}