$re = '/(\d+(?:\.\d+)?[ \'])?(\d+(?:(?:\.\d+|\d+\/\d+))?(?: \d+\/\d+)?)/';
$str = '5 6 (feet and inches separated by spaces)
5\'6" (feet and inches in the correct format)
5.2 6 (decimal feet separated by spaces)
5.2\'6" (decimal feet in the correct format)
5 6.1 (decimal inches separated by spaces)
5\'6.1" (decimal inches in the correct format)
5.2 6.1 (decimal feet and inches separated by spaces)
5.2\'6.1" (decimal feet and inches in the correct format)
5 6 1/2 (any combination above followed by a space and fraction)
5.2\'6.1 1/2" (again with decimals)
78" (only inches)
78.4" (only inches with a decimal)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);