import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+(?:\\.\\d+)?[ '])?(\\d+(?:(?:\\.\\d+|\\d+\\/\\d+))?(?: \\d+\\/\\d+)?)";
final String string = "5 6 (feet and inches separated by spaces)\n\n"
+ "5'6\" (feet and inches in the correct format)\n\n"
+ "5.2 6 (decimal feet separated by spaces)\n\n"
+ "5.2'6\" (decimal feet in the correct format)\n\n"
+ "5 6.1 (decimal inches separated by spaces)\n\n"
+ "5'6.1\" (decimal inches in the correct format)\n\n"
+ "5.2 6.1 (decimal feet and inches separated by spaces)\n\n"
+ "5.2'6.1\" (decimal feet and inches in the correct format)\n\n"
+ "5 6 1/2 (any combination above followed by a space and fraction)\n\n"
+ "5.2'6.1 1/2\" (again with decimals)\n\n"
+ "78\" (only inches)\n\n"
+ "78.4\" (only inches with a decimal)\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}