import re
regex = re.compile(r"(\d+(?:\.\d+)?[ '])?(\d+(?:(?:\.\d+|\d+\/\d+))?(?: \d+\/\d+)?)")
test_str = ("5 6 (feet and inches separated by spaces)\n\n"
"5'6\" (feet and inches in the correct format)\n\n"
"5.2 6 (decimal feet separated by spaces)\n\n"
"5.2'6\" (decimal feet in the correct format)\n\n"
"5 6.1 (decimal inches separated by spaces)\n\n"
"5'6.1\" (decimal inches in the correct format)\n\n"
"5.2 6.1 (decimal feet and inches separated by spaces)\n\n"
"5.2'6.1\" (decimal feet and inches in the correct format)\n\n"
"5 6 1/2 (any combination above followed by a space and fraction)\n\n"
"5.2'6.1 1/2\" (again with decimals)\n\n"
"78\" (only inches)\n\n"
"78.4\" (only inches with a decimal)\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")