#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)x(?:(?(1)(?!)|(a))|(?(2)(?!)|(b))|.){0,10}?y(?(1)|(?!))(?(2)|(?!))"
Local $sString = "Match:" & @CRLF & _
"...x12a456b89y... ...x12a456b89y... " & @CRLF & _
"...xaabbaabby..." & @CRLF & _
"x...a.y.b...y (there are 11 chars between x and y, no match is correct!)" & @CRLF & _
"...x..a...b..y..." & @CRLF & _
"...x..b...a..y..." & @CRLF & _
"...x..a...b..y...a..." & @CRLF & _
"...x..a...b..y...b..." & @CRLF & _
"...x..a...b..y...y..." & @CRLF & _
"...x..a.x.b..y..." & @CRLF & _
"...x..a.y.b..y..." & @CRLF & _
"...xaabbaabbay..." & @CRLF & _
"...x..a...b..y... ...x..a...b..y... (2 matches)" & @CRLF & _
"...xaby...xaby... (2 matches)" & @CRLF & _
"" & @CRLF & _
"Don't match:" & @CRLF & _
"...x..a...b......" & @CRLF & _
"...x......b..y..." & @CRLF & _
"...x..a......y..." & @CRLF & _
"...x..a...b......y..." & @CRLF & _
"...x......b..y...a..." & @CRLF & _
"...x..a......y...b..." & @CRLF & _
"...x..a.y.b......" & @CRLF & _
"...x..a.y.b......y..." & @CRLF & _
"...x..a.y.b.x....y..." & @CRLF & _
".a.x......b..y..." & @CRLF & _
".b.x..a......y..." & @CRLF & _
"x...y...a...b"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")