# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"x(?:(?(1)(?!)|(a))|(?(2)(?!)|(b))|.){0,10}?y(?(1)|(?!))(?(2)|(?!))"
test_str = ("Match:\n"
"...x12a456b89y... ...x12a456b89y... \n"
"...xaabbaabby...\n"
"x...a.y.b...y (there are 11 chars between x and y, no match is correct!)\n"
"...x..a...b..y...\n"
"...x..b...a..y...\n"
"...x..a...b..y...a...\n"
"...x..a...b..y...b...\n"
"...x..a...b..y...y...\n"
"...x..a.x.b..y...\n"
"...x..a.y.b..y...\n"
"...xaabbaabbay...\n"
"...x..a...b..y... ...x..a...b..y... (2 matches)\n"
"...xaby...xaby... (2 matches)\n\n"
"Don't match:\n"
"...x..a...b......\n"
"...x......b..y...\n"
"...x..a......y...\n"
"...x..a...b......y...\n"
"...x......b..y...a...\n"
"...x..a......y...b...\n"
"...x..a.y.b......\n"
"...x..a.y.b......y...\n"
"...x..a.y.b.x....y...\n"
".a.x......b..y...\n"
".b.x..a......y...\n"
"x...y...a...b")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.