# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/#([a-z_0-9]+)/$1/gi;t' <<< "#HelloWorld -> helloworld, #Hello_W0rld -> hello_w0rld, #Hello(World -> hello,"