package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)#([a-z_0-9]+)`)
var str = `#HelloWorld -> helloworld, #Hello_W0rld -> hello_w0rld, #Hello(World -> hello,`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}