const regex = /#([a-z_0-9]+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#([a-z_0-9]+)', 'gi')
const str = `#HelloWorld -> helloworld, #Hello_W0rld -> hello_w0rld, #Hello(World -> hello,`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);