$re = '/#([a-z_0-9]+)/i';
$str = '#HelloWorld -> helloworld, #Hello_W0rld -> hello_w0rld, #Hello(World -> hello,';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;