use strict;
my $str = '#HelloWorld -> helloworld, #Hello_W0rld -> hello_w0rld, #Hello(World -> hello,';
my $regex = qr/#([a-z_0-9]+)/ip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";