# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\w+\s+)*\w+),?\s*(?=\1\b)//gm;t' <<< "I, I, I am really wanting to go, but I I am not, am not able to do it.
you know, you know you know"