using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\w+\s+)*\w+),?\s*(?=\1\b)";
string substitution = @"";
string input = @"I, I, I am really wanting to go, but I I am not, am not able to do it.
you know, you know you know";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}