const regex = new RegExp('((?:\\w+\\s+)*\\w+),?\\s*(?=\\1\\b)', 'gm')
const str = `I, I, I am really wanting to go, but I I am not, am not able to do it.
you know, you know you know`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);