re = /((?:\w+\s+)*\w+),?\s*(?=\1\b)/m
str = 'I, I, I am really wanting to go, but I I am not, am not able to do it.
you know, you know you know'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result