# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?P<firstname>\b[A-Z][a-z]{1,}\b)\s{1}(?P<lastname>\b[A-Z][a-z]{1,}\b)$/${lastname}, ${firstname} /g;t' <<< "Andrew Jones"