import re
regex = re.compile(r"^(?P<firstname>\b[A-Z][a-z]{1,}\b)\s{1}(?P<lastname>\b[A-Z][a-z]{1,}\b)$")
test_str = "Andrew Jones"
subst = "${lastname}, ${firstname} "
result = regex.sub(subst, test_str)
if result:
print(result)