import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<firstname>\\b[A-Z][a-z]{1,}\\b)\\s{1}(?P<lastname>\\b[A-Z][a-z]{1,}\\b)$";
final String string = "Andrew Jones";
final String subst = "${lastname}, ${firstname} ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}