$re = '/^(?P<firstname>\b[A-Z][a-z]{1,}\b)\s{1}(?P<lastname>\b[A-Z][a-z]{1,}\b)$/';
$str = 'Andrew Jones';
$subst = "${lastname}, ${firstname} ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;